2012年02月09日

capistranoのbundleインストールでmysql2がインストールできない

capistranoでmysql2をbundle installしようとした時にエラーになる時の対処メモ。
Railsデプロイ
Railsデプロイ
posted with amazlet at 12.02.09
Ezra Zygmuntowicz Bruce A. Tate Clinton Begin
オライリージャパン
売り上げランキング: 76174

  * executing "cd /var/www/hoge/releases/20120208082251 && /var/lib/gems/1.8/bin/bundle install --gemfile /var/www/hoge/releases/20120208082251/Gemfile --path /var/www/hoge/shared/bundle --quiet --without development test"
  servers: ["xxx.xxx.xx.xx"]
  [xxx.xxx.xx.xx] executing command
  *** [err :: xxx.xxx.xx.xx] /usr/lib/ruby/1.8/rubygems/installer.rb:483:in `build_extensions': ERROR: Failed to build gem native extension. (Gem::Installer::ExtensionBuildError
  *** [err :: xxx.xxx.xx.xx] )
$ sudo aptitude install libmysqld-dev

これを入れて解決。

以上です。


ラベル:Rails
posted by 何某。 at 15:21| Comment(0) | TrackBack(0) | Ruby on Rails | このブログの読者になる | 更新情報をチェックする
この記事へのコメント
コメントを書く
お名前:

メールアドレス:

ホームページアドレス:

コメント:

認証コード: [必須入力]


※画像の中の文字を半角で入力してください。

この記事へのトラックバック
×

この広告は180日以上新しい記事の投稿がないブログに表示されております。